Emacs port to Android.

Forums Submission Queue Emacs port to Android.

This topic contains 11 replies, has 4 voices, and was last updated by  lj.rossia.org/users/imz/ 10 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #3031

    buggme
    Member
    #3032

    buggme
    Member
    #3365

    daithib8
    Member

    Have you tried the app, or are there no apks? It is good to try the finished article first in cases like this.

    #3725

    daithib8
    Member

    Well I’ve built it (very quick so it is) and it says a hardware keyboard is required and it asks me to download emacs from zielm.com, or one can specify a mirror. That seems ok, but one thing to worry about is the busybox binary in the assets/ directory.

    #4028

    daithib8
    Member

    I could have sworn I stopped the download yet it put 4000 files on my sdcard.

    #4317

    Emacs
    zielmicha

    GNU Emacs ported to Android!
    ** If Emacs segfaults try changing font size. This is going to be fixed. **
    ** If you have troubles pressing keys like Ctrl-Space install Hacker’s Keyboard **
    Runs on modified version of Terminal Emulator – requires hardware keyboard and a rather big display.
    Includes Busybox and eshell. SSH (for TRAMP) and git are planned.

    https://github.com/zielmicha/emacs-android

    http://michal.zielinscy.org.pl/

    License: GNU GPLv3 (original emacs is under that license and GPL doesn’t allow to change the license)

    #4318
    #4383

    I got reply: “You need to build git://git.busybox.net/busybox (I used commit 293c945) using .config from https://gist.github.com/3794647. “

    #4508

    daithib8
    Member

    Fine. There’s no need to rush him because it’ll probably be ages before somebody tries to build it: I’m not going to try this one.

    #11138

    I’ve tried recently using the Emacs app from the Play Store, but the software couldn’t be downloaded because http://emacs.zielm.com/ can’t be resolved.

    Anyway, even if that app is gone (or it doesn’t meet our standards for free and open-source software because its compilation can’t be smoothly reproduced from sources: I don’t know whether the compilation of Emacs which we were supposed to download was thoroughly described), compiling Emacs against the Android environment (to get the paths correct for an app, and correct library links) and running it from inside a nice terminal in Android must be no big conceptual problem. So someone else might try to do this eventually to get an Emacs working even in an unrooted Android.

    As for a rooted Android, it has been long known that it is possible to install a GNU/Linux distro into a chroot.

    But out of interest, I was also interested to get a running Emacs in an unrooted Android.

    As a faster solution (without recompiling Emacs against the Android environment), I’ve used the GNURoot app (with GNURoot Wheezy) which allows to use a GNU/Linux distro like Debian in an unrooted Android. There I could start Emacs, as well as ssh to my computers, and hopefully I’ll be able to use TRAMP, too. (I haven’t yet tried this out.)

    The GNURoot app does all this by means of a “PTRACE container” implemented by means of “proot” utility, i.e., interception of syscalls and “emulating” what should be done in the different Android and unprivileged environment. (Redirecting paths, faking the root user privileges, etc.)

    It was a while ago when I learned about such projects.

    It’s a pity that the source code for GNURoot seems not to be well documented, so it’s not easy to start hacking with it right away or at least learn how all the things have been compiled and put together from source. (or perhaps it’s my fault of not seeing the documentation for all the creation procedure)

    I’d like to have such an app in F-Droid, too, of course. Now there are only apps using chroot for installing and using a GNU/Linux distro, and thus requiring a rooted device. This would work on an unrooted one.

    #11140

    @lj.rossia.org/users/imz/ : please open a new issue in the submission queue or make a merge request on F-Droid gitorious for the GNURoot app. Sounds interesting.

    Regarding a new emacs port…if you start hacking on that, your app will be very welcome here.

    #11141

    Regarding a new emacs port…if you start hacking on that, your app will be very welcome here.

    Actually, I’ve overlooked the first link to the source of the build scripts — https://github.com/zielmicha/emacs-android , so one wouldn’t have to start hacking the Emacs app from scratch, as I was afraid of.

    please open a new issue in the submission queue or make a merge request on F-Droid gitorious for the GNURoot app. Sounds interesting.

    done: https://f-droid.org/forums/topic/gnuroot-or-another-ptrace-based-container-for-a-gnulinux-distro-on-an-unrooted/

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Posted in