LibreOffice Viewer

Forums Submissions Complete LibreOffice Viewer

This topic contains 22 replies, has 8 voices, and was last updated by  Spielmops 7 months, 3 weeks ago.

Viewing 8 posts - 16 through 23 (of 23 total)
  • Author
    Posts
  • #15919

    I’d be interested in bringing the updated version(s) to f-droid. If there is the need I think I can maintain the package.
    One thing I can’t figure out right now is from which branch the Android apps are built right now. From master here: http://cgit.freedesktop.org/libreoffice/core/?
    Apart from that there are the collabora/viewer and collabora/viewer2 branches. Should we build from these?

    #15926

    samtuke
    Member

    bubu1.eu/Bubu: collabora/viewer2 is the right branch to use — it is the newest and is under development. viewer1 is old and will be deleted soon.

    Looking forward to your updates 🙂

    #15927

    I’m not online again until Tuesday. I’ll see if I can get it to build then. 🙂

    #15964

    hi @samtuke , ive been busy, so i I havent updated the apk

    now im looking at this, but im not sure what branch are you using, as I cant find the commit 477f7c3 (from the last build)

    can u help me? 🙂
    ____________________________________________________________
    update: sorry, my browser didnt show the last page 🙂

    #15967

    samtuke
    Member

    Hi MatĂ­as, do you have everything that you need now?

    #15968

    Yes thanks, im compiling a test build now (my laptop es so slow u.u)

    #15975

    @samtuke the building went fine, but the apk gives me an error

    E/AndroidRuntime(7364): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.collabora.libreoffice/org.libreoffice.LibreOfficeMainActivity}: java.lang.IllegalArgumentException: AppCompat does not support the current theme features

    when using a patch[1] it works fine, so ill try to add the updated version today (tomorrow in the repo)

    cheers

    [1] https://www.mail-archive.com/libreoffice@lists.freedesktop.org/msg141934.html

    #22010

    Spielmops
    Member

    The recent version 5.0.0.0.alpha is not installable on Lollipop (two different phones …). The version at GPS is 5.2.0.0.alpha and is installable and runs fine.

    Spielmops

Viewing 8 posts - 16 through 23 (of 23 total)

The forum ‘Submissions Complete’ is closed to new topics and replies.

Posted in