package icon

DroidWall

Firewall frontend

N.B Development of this app ceased in mid 2012. Use AFWall+ instead.

Tap the tab at the top to switch between whitelist and blacklist mode. Tap Menu and Apply Changes to apply.

Recommended platforms are Android 1.6 to 2.3.7.

Requires root: Yes. iptables (the firewall itself) has to be run as root.

Packages

Although APK downloads are available below to give you the choice, you should be aware that by installing that way you will not receive update notifications and it's a less secure way to download. We recommend that you install the F-Droid client and use that.

Download F-Droid
  • Version 1.5.7 (157) suggested Added on 2013-05-10

    This version requires Android 1.6 or newer.

    It is built and signed by F-Droid, and guaranteed to correspond to this source tarball.

    Permissions
    • run at startup
      Allows the app to have itself started as soon as the system has finished booting. This can make it take longer to start the phone and allow the app to slow down the overall phone by always running.

    Download APK 0.6 MiB PGP Signature | Build Log