ch.admin.bag.covidcertificate.verifier/lastbuild 2610

From F-Droid
Revision as of 05:41, 16 October 2021 by Robot (Talk | contribs) (Build log)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Installed Android Tools

Build Log

'Build.py failed on server for ch.admin.bag.covidcertificate.verifier:2.6.1'

detail

== Installed Android Tools ==

2021-10-16 05:40:53,668 DEBUG: Reading 'config.yml'
2021-10-16 05:40:53,678 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2021-10-16 05:40:53,680 INFO: Creating log directory
2021-10-16 05:40:53,680 INFO: Creating temporary directory
2021-10-16 05:40:53,681 INFO: Creating output directory
2021-10-16 05:40:53,684 DEBUG: Getting git vcs interface for https://github.com/admin-ch/CovidCertificate-App-Android
2021-10-16 05:40:53,685 DEBUG: > git --version
git version 2.11.0
2021-10-16 05:40:53,896 INFO: Using git version 2.11.0
2021-10-16 05:40:53,896 DEBUG: Checking 2.6.1
2021-10-16 05:40:53,897 INFO: Building version 2.6.1 (2610) of ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:53,898 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2021-10-16 05:40:54,108 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64914 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u13) ...
2021-10-16 05:40:57,455 INFO: Getting source for revision be10120e4581ef8c242ccbb882fec93cb8ef1c47
2021-10-16 05:40:57,455 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:57,456 DEBUG: > git rev-parse --show-toplevel
2021-10-16 05:40:57,661 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:57,662 DEBUG: > git submodule foreach --recursive git reset --hard
2021-10-16 05:40:57,768 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:57,768 DEBUG: > git reset --hard
2021-10-16 05:40:58,079 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:58,079 DEBUG: > git submodule foreach --recursive git clean -dffx
2021-10-16 05:40:58,187 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:58,187 DEBUG: > git clean -dffx
2021-10-16 05:40:58,294 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:58,294 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2021-10-16 05:40:58,708 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:58,708 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2021-10-16 05:40:59,024 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:59,025 DEBUG: > git remote set-head origin --auto
2021-10-16 05:40:59,433 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:59,434 DEBUG: > git checkout -f be10120e4581ef8c242ccbb882fec93cb8ef1c47
2021-10-16 05:40:59,743 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier
2021-10-16 05:40:59,744 DEBUG: > git clean -dffx
2021-10-16 05:40:59,849 INFO: Creating local.properties file at build/ch.admin.bag.covidcertificate.verifier/local.properties
2021-10-16 05:40:59,851 INFO: Creating local.properties file at build/ch.admin.bag.covidcertificate.verifier/verifier/local.properties
2021-10-16 05:40:59,852 DEBUG: Removing debuggable flags from build/ch.admin.bag.covidcertificate.verifier/verifier
2021-10-16 05:40:59,857 INFO: Removing specified files
2021-10-16 05:40:59,857 INFO: Removing verifier/testKeystore
2021-10-16 05:40:59,858 INFO: Removing wallet/testKeystore
2021-10-16 05:40:59,860 INFO: Cleaned build.gradle of keysigning configs at build/ch.admin.bag.covidcertificate.verifier/wallet/build.gradle
2021-10-16 05:40:59,865 INFO: Cleaned build.gradle of keysigning configs at build/ch.admin.bag.covidcertificate.verifier/verifier/build.gradle
2021-10-16 05:40:59,871 INFO: Running 'prebuild' commands in build/ch.admin.bag.covidcertificate.verifier/verifier
2021-10-16 05:40:59,871 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier/verifier
2021-10-16 05:40:59,872 DEBUG: > bash -x -c -- printf '\nbuildTimestamp=%s\n' "$(curl -sL https://github.com/admin-ch/CovidCertificate-App-Android/releases/download/v2.6.1-2610-verifier/verifier-prod-2.6.1-2610-buildtimestamp.txt | tr -cd '0-9')" >> gradle.properties
++ curl -sL https://github.com/admin-ch/CovidCertificate-App-Android/releases/download/v2.6.1-2610-verifier/verifier-prod-2.6.1-2610-buildtimestamp.txt
++ tr -cd 0-9
+ printf '\nbuildTimestamp=%s\n' 1634137396099
2021-10-16 05:41:00,476 INFO: Cleaning Gradle project...
2021-10-16 05:41:00,477 DEBUG: Directory: build/ch.admin.bag.covidcertificate.verifier/verifier
2021-10-16 05:41:00,477 DEBUG: > /home/vagrant/fdroidserver/gradlew-fdroid clean
Found 7.0.2 via distributionUrl
Running /opt/gradle/versions/7.0.2/bin/gradle clean

Welcome to Gradle 7.0.2!

Here are the highlights of this release:
 - File system watching enabled by default
 - Support for running with and building Java 16 projects
 - Native support for Apple Silicon processors
 - Dependency catalog feature preview

For more details see https://docs.gradle.org/7.0.2/release-notes.html

To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.0.2/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'CovidCertificate'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not resolve ch.ubique.gradle:ubdiag-android:7.0.2.
     Required by:
         project :
      > No matching variant of ch.ubique.gradle:ubdiag-android:7.0.2 was found. The consumer was configured to find a runtime of a library compatible with Java 8, packaged as a jar, and its dependencies declared externally, as well as attribute 'org.gradle.plugin.api-version' with value '7.0.2' but:
          - Variant 'apiElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares an API of a component compatible with Java 11 and the consumer needed a runtime of a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')
          - Variant 'runtimeElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares a component compatible with Java 11 and the consumer needed a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 10s
2021-10-16 05:41:11,900 ERROR: Could not build app ch.admin.bag.covidcertificate.verifier: Error cleaning ch.admin.bag.covidcertificate.verifier:2.6.1
==== detail begin ====
Found 7.0.2 via distributionUrl
Running /opt/gradle/versions/7.0.2/bin/gradle clean

Welcome to Gradle 7.0.2!

Here are the highlights of this release:
 - File system watching enabled by default
 - Support for running with and building Java 16 projects
 - Native support for Apple Silicon processors
 - Dependency catalog feature preview

For more details see https://docs.gradle.org/7.0.2/release-notes.html

To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.0.2/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'CovidCertificate'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not resolve ch.ubique.gradle:ubdiag-android:7.0.2.
     Required by:
         project :
      > No matching variant of ch.ubique.gradle:ubdiag-android:7.0.2 was found. The consumer was configured to find a runtime of a library compatible with Java 8, packaged as a jar, and its dependencies declared externally, as well as attribute 'org.gradle.plugin.api-version' with value '7.0.2' but:
          - Variant 'apiElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares an API of a component compatible with Java 11 and the consumer needed a runtime of a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')
          - Variant 'runtimeElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares a component compatible with Java 11 and the consumer needed a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 10s
==== detail end ====
2021-10-16 05:41:11,900 DEBUG: Error encoutered, stopping by user request.