Difference between revisions of "com.coinerella.peercoin/lastbuild 60"

From F-Droid
Jump to: navigation, search
(Build log)
 
(Build log)
 
Line 1: Line 1:
* build session started at 2021-10-09 10:06:39Z
+
* build session started at 2021-10-11 17:49:25Z
* this build started at 2021-10-09 23:10:22Z
+
* this build started at 2021-10-12 02:01:40Z
* this build completed at 2021-10-09 23:15:25Z
+
* this build completed at 2021-10-12 02:12:22Z
* fdroiddata: [https://gitlab.com/fdroid/fdroiddata/commit/57bd1eaa7958fdebc5fa2727bac84aabfc21e970 57bd1eaa7958fdebc5fa2727bac84aabfc21e970]
+
* fdroiddata: [https://gitlab.com/fdroid/fdroiddata/commit/620fbcfdd58fbf07951d20557da1fda6a091a110 620fbcfdd58fbf07951d20557da1fda6a091a110]
 
* fdroidserverid: [https://gitlab.com/fdroid/fdroidserver/commit/bd079c9311737094e441e9a3e19f8841e9825b89 bd079c9311737094e441e9a3e19f8841e9825b89]
 
* fdroidserverid: [https://gitlab.com/fdroid/fdroidserver/commit/bd079c9311737094e441e9a3e19f8841e9825b89 bd079c9311737094e441e9a3e19f8841e9825b89]
  
Line 9: Line 9:
 
== Installed Android Tools ==
 
== Installed Android Tools ==
  
 +
* build-tools/19.1.0 (19.1)
 +
* build-tools/20.0.0 (20)
 +
* build-tools/21.1.2 (21.1.2)
 +
* build-tools/22.0.1 (22.0.1)
 +
* build-tools/23.0.1 (23.0.1)
 +
* build-tools/23.0.2 (23.0.2)
 +
* build-tools/23.0.3 (23.0.3)
 +
* build-tools/24.0.0 (24)
 +
* build-tools/24.0.1 (24.0.1)
 +
* build-tools/24.0.2 (24.0.2)
 +
* build-tools/24.0.3 (24.0.3)
 +
* build-tools/25.0.0 (25)
 +
* build-tools/25.0.1 (25.0.1)
 +
* build-tools/25.0.2 (25.0.2)
 +
* build-tools/25.0.3 (25.0.3)
 +
* build-tools/26.0.0 (26)
 +
* build-tools/26.0.1 (26.0.1)
 +
* build-tools/26.0.2 (26.0.2)
 +
* build-tools/26.0.3 (26.0.3)
 +
* build-tools/27.0.0 (27)
 +
* build-tools/27.0.1 (27.0.1)
 +
* build-tools/27.0.2 (27.0.2)
 +
* build-tools/27.0.3 (27.0.3)
 +
* build-tools/28.0.0 (28)
 +
* build-tools/28.0.1 (28.0.1)
 +
* build-tools/28.0.2 (28.0.2)
 +
* build-tools/28.0.3 (28.0.3)
 +
* build-tools/29.0.2 (29.0.2)
 +
* build-tools/29.0.3 (29.0.3)
 +
* extras/android/m2repository (47.0.0)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.1 (1)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.2 (1)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout/1.0.1 (1)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout/1.0.2 (1)
 +
* ndk/21.4.7075529 (21.4.7075529)
 +
* ndk/22.1.7171670 (22.1.7171670)
 +
* platform-tools (29.0.6)
 +
* platforms/android-10 (2)
 +
* platforms/android-11 (2)
 +
* platforms/android-12 (3)
 +
* platforms/android-13 (1)
 +
* platforms/android-14 (4)
 +
* platforms/android-15 (5)
 +
* platforms/android-16 (5)
 +
* platforms/android-17 (3)
 +
* platforms/android-18 (3)
 +
* platforms/android-19 (4)
 +
* platforms/android-20 (2)
 +
* platforms/android-21 (2)
 +
* platforms/android-22 (2)
 +
* platforms/android-23 (3)
 +
* platforms/android-24 (2)
 +
* platforms/android-25 (3)
 +
* platforms/android-26 (2)
 +
* platforms/android-27 (3)
 +
* platforms/android-28 (6)
 +
* platforms/android-29 (4)
 +
* platforms/android-7 (3)
 +
* platforms/android-8 (3)
 +
* platforms/android-9 (2)
 +
* r21e (None)
 +
* r22b (None)
 +
* tools (25.2.5)
  
  
 
== Build Log ==
 
== Build Log ==
  
'Build.py failed on server for com.coinerella.peercoin:0.6.4'
+
Build succeeded
=detail=
+
<pre>
+
== Installed Android Tools ==
+
 
+
2021-10-09 23:14:09,245 DEBUG: Reading 'config.yml'
+
2021-10-09 23:14:09,254 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner
+
2021-10-09 23:14:09,257 INFO: Creating log directory
+
2021-10-09 23:14:09,257 INFO: Creating temporary directory
+
2021-10-09 23:14:09,258 INFO: Creating output directory
+
2021-10-09 23:14:09,261 DEBUG: Getting git vcs interface for https://github.com/peercoin/peercoin_flutter
+
2021-10-09 23:14:09,262 DEBUG: > git --version
+
git version 2.11.0
+
2021-10-09 23:14:09,472 INFO: Using git version 2.11.0
+
2021-10-09 23:14:09,473 DEBUG: Checking 0.6.4
+
2021-10-09 23:14:09,474 INFO: Building version 0.6.4 (60) of com.coinerella.peercoin
+
2021-10-09 23:14:09,475 DEBUG: > sudo passwd --lock root
+
passwd: password expiry information changed.
+
2021-10-09 23:14:09,686 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
+
(Reading database ... 64914 files and directories currently installed.)
+
Removing sudo (1.8.19p1-2.1+deb9u3) ...
+
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
+
Processing triggers for systemd (232-25+deb9u13) ...
+
2021-10-09 23:14:13,362 INFO: Getting source for revision 4c681ecb8320420e2cde0e86013a8d661047b2dc
+
2021-10-09 23:14:13,363 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:13,363 DEBUG: > git rev-parse --show-toplevel
+
2021-10-09 23:14:13,567 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:13,567 DEBUG: > git submodule foreach --recursive git reset --hard
+
2021-10-09 23:14:13,672 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:13,673 DEBUG: > git reset --hard
+
2021-10-09 23:14:13,878 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:13,878 DEBUG: > git submodule foreach --recursive git clean -dffx
+
2021-10-09 23:14:13,984 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:13,984 DEBUG: > git clean -dffx
+
2021-10-09 23:14:14,089 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:14,089 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
+
2021-10-09 23:14:14,495 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:14,495 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
+
2021-10-09 23:14:14,813 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:14,814 DEBUG: > git remote set-head origin --auto
+
2021-10-09 23:14:15,224 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:15,224 DEBUG: > git checkout -f 4c681ecb8320420e2cde0e86013a8d661047b2dc
+
2021-10-09 23:14:15,429 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:15,430 DEBUG: > git clean -dffx
+
2021-10-09 23:14:15,535 INFO: Collecting source libraries
+
2021-10-09 23:14:15,615 DEBUG: Removing debuggable flags from build/srclib/flutter
+
2021-10-09 23:14:15,666 INFO: Creating local.properties file at build/com.coinerella.peercoin/local.properties
+
2021-10-09 23:14:15,666 DEBUG: Removing debuggable flags from build/com.coinerella.peercoin
+
2021-10-09 23:14:15,672 INFO: Removing specified files
+
2021-10-09 23:14:15,672 INFO: Removing test_driver
+
2021-10-09 23:14:15,673 INFO: Removing ios/build
+
2021-10-09 23:14:15,676 INFO: Cleaned build.gradle of keysigning configs at build/com.coinerella.peercoin/android/app/build.gradle
+
2021-10-09 23:14:15,680 INFO: Running 'prebuild' commands in build/com.coinerella.peercoin
+
2021-10-09 23:14:15,680 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:15,680 DEBUG: > bash -x -c -- echo "flutter.sdk=/home/vagrant/build/srclib/flutter" >> ../local.properties
+
+ echo flutter.sdk=/home/vagrant/build/srclib/flutter
+
2021-10-09 23:14:15,893 INFO: Scanning source for common problems...
+
2021-10-09 23:14:15,908 INFO: Creating source tarball...
+
2021-10-09 23:14:16,197 INFO: Running 'build' commands in build/com.coinerella.peercoin
+
2021-10-09 23:14:16,197 DEBUG: Directory: build/com.coinerella.peercoin
+
2021-10-09 23:14:16,197 DEBUG: > bash -x -c /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics && /home/vagrant/build/srclib/flutter/bin/flutter pub get && /home/vagrant/build/srclib/flutter/bin/flutter pub run flutter_launcher_icons:main -f fdroid_flutter_launcher_icons.yaml && /home/vagrant/build/srclib/flutter/bin/flutter pub run flutter_native_splash:create && /home/vagrant/build/srclib/flutter/bin/flutter packages pub run build_runner build --delete-conflicting-outputs && /home/vagrant/build/srclib/flutter/bin/flutter build apk
+
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
+
Downloading Dart SDK from Flutter engine 241c87ad800beeab545ab867354d4683d5bfb6ce...
+
  % Total    % Received % Xferd  Average Speed  Time    Time    Time  Current
+
                                Dload  Upload  Total  Spent    Left  Speed
+
 
+
  0    0    0    0    0    0      0      0 --:--:-- --:--:-- --:--:--    0
+
  4  199M    4 8431k    0    0  12.4M      0  0:00:15 --:--:--  0:00:15 12.4M
+
53  199M  53  106M    0    0  66.5M      0  0:00:02  0:00:01  0:00:01 66.5M
+
100  199M  100  199M    0    0  78.4M      0  0:00:02  0:00:02 --:--:-- 78.4M
+
Building flutter tool...
+
 
+
  ╔════════════════════════════════════════════════════════════════════════════╗
+
  ║                Welcome to Flutter! - https://flutter.dev                  ║
+
  ║                                                                            ║
+
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
+
  ║ statistics and basic crash reports. This data is used to help improve      ║
+
  ║ Flutter tools over time.                                                  ║
+
  ║                                                                            ║
+
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
+
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
+
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
+
  ║ event will be sent, and then no further information will be sent by the    ║
+
  ║ Flutter tool.                                                              ║
+
  ║                                                                            ║
+
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
+
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
+
  ║ service.                                                                  ║
+
  ║                                                                            ║
+
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
+
  ║ crash reports to Google.                                                  ║
+
  ║                                                                            ║
+
  ║ Read about data we send with crash reports:                                ║
+
  ║ https://flutter.dev/docs/reference/crash-reporting                        ║
+
  ║                                                                            ║
+
  ║ See Google's privacy policy:                                              ║
+
  ║ https://policies.google.com/privacy                                        ║
+
  ╚════════════════════════════════════════════════════════════════════════════╝
+
 
+
Analytics reporting disabled.
+
 
+
You may need to restart any open editors for them to read new settings.
+
+ /home/vagrant/build/srclib/flutter/bin/flutter pub get
+
Downloading Material fonts...                                      594ms
+
Downloading Gradle Wrapper...                                      134ms
+
Downloading package sky_engine...                                  166ms
+
Downloading flutter_patched_sdk tools...                          442ms
+
Downloading flutter_patched_sdk_product tools...                  404ms
+
Downloading linux-x64 tools...                                  2,692ms
+
Downloading linux-x64/font-subset tools...                        475ms
+
Running "flutter pub get" in com.coinerella.peercoin...       
+
The current Dart SDK version is 2.13.4.
+
 
+
 
+
 
+
Because no versions of flutter_native_splash match >1.2.4 <2.0.0 and flutter_native_splash 1.2.4 depends on xml ^5.3.0, flutter_native_splash ^1.2.4 requires xml ^5.3.0.
+
 
+
Because xml 5.3.0 requires SDK version >=2.14.0 <3.0.0 and no versions of xml match >5.3.0 <6.0.0, xml ^5.3.0 is forbidden.
+
 
+
Thus, flutter_native_splash ^1.2.4 is forbidden.
+
 
+
So, because peercoin depends on flutter_native_splash ^1.2.4, version solving failed.
+
pub get failed (1; So, because peercoin depends on flutter_native_splash ^1.2.4, version solving failed.)
+
2021-10-09 23:15:03,424 ERROR: Could not build app com.coinerella.peercoin: Error running build command for com.coinerella.peercoin:0.6.4
+
==== detail begin ====
+
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
+
Downloading Dart SDK from Flutter engine 241c87ad800beeab545ab867354d4683d5bfb6ce...
+
  % Total    % Received % Xferd  Average Speed  Time    Time    Time  Current
+
                                Dload  Upload  Total  Spent    Left  Speed
+
 
+
  0    0    0    0    0    0      0      0 --:--:-- --:--:-- --:--:--    0
+
  4  199M    4 8431k    0    0  12.4M      0  0:00:15 --:--:--  0:00:15 12.4M
+
53  199M  53  106M    0    0  66.5M      0  0:00:02  0:00:01  0:00:01 66.5M
+
100  199M  100  199M    0    0  78.4M      0  0:00:02  0:00:02 --:--:-- 78.4M
+
Building flutter tool...
+
 
+
  ╔════════════════════════════════════════════════════════════════════════════╗
+
  ║                Welcome to Flutter! - https://flutter.dev                  ║
+
  ║                                                                            ║
+
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
+
  ║ statistics and basic crash reports. This data is used to help improve      ║
+
  ║ Flutter tools over time.                                                  ║
+
  ║                                                                            ║
+
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
+
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
+
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
+
  ║ event will be sent, and then no further information will be sent by the    ║
+
  ║ Flutter tool.                                                              ║
+
  ║                                                                            ║
+
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
+
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
+
  ║ service.                                                                  ║
+
  ║                                                                            ║
+
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
+
  ║ crash reports to Google.                                                  ║
+
  ║                                                                            ║
+
  ║ Read about data we send with crash reports:                                ║
+
  ║ https://flutter.dev/docs/reference/crash-reporting                        ║
+
  ║                                                                            ║
+
  ║ See Google's privacy policy:                                              ║
+
  ║ https://policies.google.com/privacy                                        ║
+
  ╚════════════════════════════════════════════════════════════════════════════╝
+
 
+
Analytics reporting disabled.
+
 
+
You may need to restart any open editors for them to read new settings.
+
+ /home/vagrant/build/srclib/flutter/bin/flutter pub get
+
Downloading Material fonts...                                      594ms
+
Downloading Gradle Wrapper...                                      134ms
+
Downloading package sky_engine...                                  166ms
+
Downloading flutter_patched_sdk tools...                          442ms
+
Downloading flutter_patched_sdk_product tools...                  404ms
+
Downloading linux-x64 tools...                                  2,692ms
+
Downloading linux-x64/font-subset tools...                        475ms
+
Running "flutter pub get" in com.coinerella.peercoin...       
+
The current Dart SDK version is 2.13.4.
+
 
+
 
+
 
+
Because no versions of flutter_native_splash match >1.2.4 <2.0.0 and flutter_native_splash 1.2.4 depends on xml ^5.3.0, flutter_native_splash ^1.2.4 requires xml ^5.3.0.
+
 
+
Because xml 5.3.0 requires SDK version >=2.14.0 <3.0.0 and no versions of xml match >5.3.0 <6.0.0, xml ^5.3.0 is forbidden.
+
 
+
Thus, flutter_native_splash ^1.2.4 is forbidden.
+
 
+
So, because peercoin depends on flutter_native_splash ^1.2.4, version solving failed.
+
pub get failed (1; So, because peercoin depends on flutter_native_splash ^1.2.4, version solving failed.)
+
==== detail end ====
+
2021-10-09 23:15:03,424 DEBUG: Error encoutered, stopping by user request.
+
</pre>
+

Latest revision as of 02:12, 12 October 2021

Installed Android Tools

  • build-tools/19.1.0 (19.1)
  • build-tools/20.0.0 (20)
  • build-tools/21.1.2 (21.1.2)
  • build-tools/22.0.1 (22.0.1)
  • build-tools/23.0.1 (23.0.1)
  • build-tools/23.0.2 (23.0.2)
  • build-tools/23.0.3 (23.0.3)
  • build-tools/24.0.0 (24)
  • build-tools/24.0.1 (24.0.1)
  • build-tools/24.0.2 (24.0.2)
  • build-tools/24.0.3 (24.0.3)
  • build-tools/25.0.0 (25)
  • build-tools/25.0.1 (25.0.1)
  • build-tools/25.0.2 (25.0.2)
  • build-tools/25.0.3 (25.0.3)
  • build-tools/26.0.0 (26)
  • build-tools/26.0.1 (26.0.1)
  • build-tools/26.0.2 (26.0.2)
  • build-tools/26.0.3 (26.0.3)
  • build-tools/27.0.0 (27)
  • build-tools/27.0.1 (27.0.1)
  • build-tools/27.0.2 (27.0.2)
  • build-tools/27.0.3 (27.0.3)
  • build-tools/28.0.0 (28)
  • build-tools/28.0.1 (28.0.1)
  • build-tools/28.0.2 (28.0.2)
  • build-tools/28.0.3 (28.0.3)
  • build-tools/29.0.2 (29.0.2)
  • build-tools/29.0.3 (29.0.3)
  • extras/android/m2repository (47.0.0)
  • extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.1 (1)
  • extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.2 (1)
  • extras/m2repository/com/android/support/constraint/constraint-layout/1.0.1 (1)
  • extras/m2repository/com/android/support/constraint/constraint-layout/1.0.2 (1)
  • ndk/21.4.7075529 (21.4.7075529)
  • ndk/22.1.7171670 (22.1.7171670)
  • platform-tools (29.0.6)
  • platforms/android-10 (2)
  • platforms/android-11 (2)
  • platforms/android-12 (3)
  • platforms/android-13 (1)
  • platforms/android-14 (4)
  • platforms/android-15 (5)
  • platforms/android-16 (5)
  • platforms/android-17 (3)
  • platforms/android-18 (3)
  • platforms/android-19 (4)
  • platforms/android-20 (2)
  • platforms/android-21 (2)
  • platforms/android-22 (2)
  • platforms/android-23 (3)
  • platforms/android-24 (2)
  • platforms/android-25 (3)
  • platforms/android-26 (2)
  • platforms/android-27 (3)
  • platforms/android-28 (6)
  • platforms/android-29 (4)
  • platforms/android-7 (3)
  • platforms/android-8 (3)
  • platforms/android-9 (2)
  • r21e (None)
  • r22b (None)
  • tools (25.2.5)


Build Log

Build succeeded