Difference between revisions of "souch.smp/lastbuild 17"

From F-Droid
Jump to: navigation, search
(Build log)
(Build log)
Line 1: Line 1:
* build session started at 2020-10-27 11:14:56Z
+
* build session started at 2020-10-28 07:00:12Z
* this build started at 2020-10-27 11:27:10Z
+
* this build started at 2020-10-28 10:00:23Z
* this build completed at 2020-10-27 11:27:19Z
+
* this build completed at 2020-10-28 10:02:34Z
* fdroiddata: [https://gitlab.com/fdroid/fdroiddata/commit/0ab5d3fda8e7f9c59b4db569c159d41ba34fed8c 0ab5d3fda8e7f9c59b4db569c159d41ba34fed8c]
+
* fdroiddata: [https://gitlab.com/fdroid/fdroiddata/commit/b2e64f56dd743efbd24bf72cf3d58663a88f2bd9 b2e64f56dd743efbd24bf72cf3d58663a88f2bd9]
 
* fdroidserverid: [https://gitlab.com/fdroid/fdroidserver/commit/1f7228d53859f078698468b2e0bbe48485e4ece7 1f7228d53859f078698468b2e0bbe48485e4ece7]
 
* fdroidserverid: [https://gitlab.com/fdroid/fdroidserver/commit/1f7228d53859f078698468b2e0bbe48485e4ece7 1f7228d53859f078698468b2e0bbe48485e4ece7]
 +
 +
* buildserverid: [https://gitlab.com/fdroid/fdroidserver/commit/06766ba48b079e2e8a13af15bf1cfbdb38365ca5 06766ba48b079e2e8a13af15bf1cfbdb38365ca5]
  
 
== Installed Android Tools ==
 
== Installed Android Tools ==
Line 11: Line 13:
 
== Build Log ==
 
== Build Log ==
  
"could not bring up vm 'builder_default'"
+
'Build.py failed on server for souch.smp:1.4.1'
 +
=detail=
 +
<pre>
 +
== Installed Android Tools ==
 +
 
 +
2020-10-28 10:01:39,595 INFO: Creating log directory
 +
2020-10-28 10:01:39,596 INFO: Creating temporary directory
 +
2020-10-28 10:01:39,596 INFO: Creating output directory
 +
2020-10-28 10:01:42,763 INFO: Using git version 2.11.0
 +
2020-10-28 10:01:42,764 INFO: Building version 1.4.1 (17) of souch.smp
 +
2020-10-28 10:01:46,250 INFO: Getting source for revision v1.4.1
 +
2020-10-28 10:01:49,199 INFO: Creating local.properties file at build/souch.smp/local.properties
 +
2020-10-28 10:01:49,200 INFO: Creating local.properties file at build/souch.smp/app/local.properties
 +
2020-10-28 10:01:49,205 INFO: Cleaned build.gradle of keysigning configs at build/souch.smp/app/build.gradle
 +
2020-10-28 10:01:49,209 INFO: Cleaning Gradle project...
 +
2020-10-28 10:02:04,848 INFO: Scanning source for common problems...
 +
2020-10-28 10:02:04,856 INFO: Removing gradle-wrapper.jar at gradle/wrapper/gradle-wrapper.jar
 +
2020-10-28 10:02:04,867 INFO: Creating source tarball...
 +
2020-10-28 10:02:05,021 INFO: Building Gradle project...
 +
2020-10-28 10:02:15,753 ERROR: Could not build app souch.smp: Build failed for souch.smp:1.4.1
 +
==== detail begin ====
 +
Found 4.4 via distributionUrl
 +
Running /opt/gradle/versions/4.4/bin/gradle assembleRelease
 +
WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
 +
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
 +
WARNING: Configuration 'androidTestCompile' is obsolete and has been replaced with 'androidTestImplementation' and 'androidTestApi'.
 +
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
 +
WARNING: Configuration 'androidTestApi' is obsolete and has been replaced with 'androidTestImplementation'.
 +
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
 +
:app:preBuild UP-TO-DATE
 +
:app:preReleaseBuild
 +
:app:compileReleaseAidl
 +
:app:compileReleaseRenderscript
 +
:app:checkReleaseManifest
 +
:app:generateReleaseBuildConfig
 +
:app:prepareLintJar
 +
:app:mainApkListPersistenceRelease
 +
:app:generateReleaseResValues
 +
:app:generateReleaseResources
 +
:app:mergeReleaseResources
 +
:app:createReleaseCompatibleScreenManifests
 +
:app:processReleaseManifest
 +
:app:splitsDiscoveryTaskRelease
 +
:app:processReleaseResources
 +
:app:generateReleaseSources
 +
:app:javaPreCompileRelease
 +
:app:compileReleaseJavaWithJavacNote: Some input files use or override a deprecated API.
 +
Note: Recompile with -Xlint:deprecation for details.
 +
Note: /home/vagrant/build/souch.smp/app/src/main/java/souch/smp/Rows.java uses unchecked or unsafe operations.
 +
Note: Recompile with -Xlint:unchecked for details.
 +
 
 +
:app:compileReleaseNdk NO-SOURCE
 +
:app:compileReleaseSources
 +
:app:lintVitalRelease FAILED
 +
 
 +
FAILURE: Build failed with an exception.
 +
 
 +
* What went wrong:
 +
Execution failed for task ':app:lintVitalRelease'.
 +
> Could not resolve all files for configuration ':app:lintClassPath'.
 +
  > Could not find com.android.tools.lint:lint-gradle:26.1.3.
 +
    Searched in the following locations:
 +
        file:/home/vagrant/android-sdk/extras/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
 +
        file:/home/vagrant/android-sdk/extras/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
 +
        file:/home/vagrant/android-sdk/extras/google/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
 +
        file:/home/vagrant/android-sdk/extras/google/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
 +
        file:/home/vagrant/android-sdk/extras/android/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
 +
        file:/home/vagrant/android-sdk/extras/android/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
 +
        https://jcenter.bintray.com/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
 +
        https://jcenter.bintray.com/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
 +
    Required by:
 +
        project :app
 +
 
 +
* Try:
 +
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
 +
 
 +
* Get more help at https://help.gradle.org
 +
 
 +
BUILD FAILED in 10s
 +
16 actionable tasks: 16 executed
 +
==== detail end ====
 +
</pre>

Revision as of 10:02, 28 October 2020

Installed Android Tools

Build Log

'Build.py failed on server for souch.smp:1.4.1'

detail

== Installed Android Tools ==

2020-10-28 10:01:39,595 INFO: Creating log directory
2020-10-28 10:01:39,596 INFO: Creating temporary directory
2020-10-28 10:01:39,596 INFO: Creating output directory
2020-10-28 10:01:42,763 INFO: Using git version 2.11.0
2020-10-28 10:01:42,764 INFO: Building version 1.4.1 (17) of souch.smp
2020-10-28 10:01:46,250 INFO: Getting source for revision v1.4.1
2020-10-28 10:01:49,199 INFO: Creating local.properties file at build/souch.smp/local.properties
2020-10-28 10:01:49,200 INFO: Creating local.properties file at build/souch.smp/app/local.properties
2020-10-28 10:01:49,205 INFO: Cleaned build.gradle of keysigning configs at build/souch.smp/app/build.gradle
2020-10-28 10:01:49,209 INFO: Cleaning Gradle project...
2020-10-28 10:02:04,848 INFO: Scanning source for common problems...
2020-10-28 10:02:04,856 INFO: Removing gradle-wrapper.jar at gradle/wrapper/gradle-wrapper.jar
2020-10-28 10:02:04,867 INFO: Creating source tarball...
2020-10-28 10:02:05,021 INFO: Building Gradle project...
2020-10-28 10:02:15,753 ERROR: Could not build app souch.smp: Build failed for souch.smp:1.4.1
==== detail begin ====
Found 4.4 via distributionUrl
Running /opt/gradle/versions/4.4/bin/gradle assembleRelease
WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
WARNING: Configuration 'androidTestCompile' is obsolete and has been replaced with 'androidTestImplementation' and 'androidTestApi'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
WARNING: Configuration 'androidTestApi' is obsolete and has been replaced with 'androidTestImplementation'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
:app:preBuild UP-TO-DATE
:app:preReleaseBuild
:app:compileReleaseAidl
:app:compileReleaseRenderscript
:app:checkReleaseManifest
:app:generateReleaseBuildConfig
:app:prepareLintJar
:app:mainApkListPersistenceRelease
:app:generateReleaseResValues
:app:generateReleaseResources
:app:mergeReleaseResources
:app:createReleaseCompatibleScreenManifests
:app:processReleaseManifest
:app:splitsDiscoveryTaskRelease
:app:processReleaseResources
:app:generateReleaseSources
:app:javaPreCompileRelease
:app:compileReleaseJavaWithJavacNote: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /home/vagrant/build/souch.smp/app/src/main/java/souch/smp/Rows.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

:app:compileReleaseNdk NO-SOURCE
:app:compileReleaseSources
:app:lintVitalRelease FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:lintVitalRelease'.
> Could not resolve all files for configuration ':app:lintClassPath'.
   > Could not find com.android.tools.lint:lint-gradle:26.1.3.
     Searched in the following locations:
         file:/home/vagrant/android-sdk/extras/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
         file:/home/vagrant/android-sdk/extras/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
         file:/home/vagrant/android-sdk/extras/google/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
         file:/home/vagrant/android-sdk/extras/google/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
         file:/home/vagrant/android-sdk/extras/android/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
         file:/home/vagrant/android-sdk/extras/android/m2repository/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
         https://jcenter.bintray.com/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.pom
         https://jcenter.bintray.com/com/android/tools/lint/lint-gradle/26.1.3/lint-gradle-26.1.3.jar
     Required by:
         project :app

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 10s
16 actionable tasks: 16 executed
==== detail end ====