Difference between revisions of "wtf.technodisaster.tldr/lastbuild 5"

From F-Droid
Jump to: navigation, search
(Build log)
(Build log)
 
Line 1: Line 1:
* build session started at 2021-10-25 20:14:16Z
+
* build session started at 2021-10-26 23:45:28Z
* this build started at 2021-10-25 23:22:39Z
+
* this build started at 2021-10-27 00:02:11Z
* this build completed at 2021-10-25 23:29:08Z
+
* this build completed at 2021-10-27 00:12:22Z
* fdroiddata: [https://gitlab.com/fdroid/fdroiddata/commit/93e1180f99935466721378b1ec2b819e2fe6ce88 93e1180f99935466721378b1ec2b819e2fe6ce88]
+
* fdroiddata: [https://gitlab.com/fdroid/fdroiddata/commit/bcc3c45cea4d3b6830ec37dd6d0e288d1c848508 bcc3c45cea4d3b6830ec37dd6d0e288d1c848508]
 
* fdroidserverid: [https://gitlab.com/fdroid/fdroidserver/commit/bd079c9311737094e441e9a3e19f8841e9825b89 bd079c9311737094e441e9a3e19f8841e9825b89]
 
* fdroidserverid: [https://gitlab.com/fdroid/fdroidserver/commit/bd079c9311737094e441e9a3e19f8841e9825b89 bd079c9311737094e441e9a3e19f8841e9825b89]
  
Line 9: Line 9:
 
== Installed Android Tools ==
 
== Installed Android Tools ==
  
 +
* build-tools/19.1.0 (19.1)
 +
* build-tools/20.0.0 (20)
 +
* build-tools/21.1.2 (21.1.2)
 +
* build-tools/22.0.1 (22.0.1)
 +
* build-tools/23.0.1 (23.0.1)
 +
* build-tools/23.0.2 (23.0.2)
 +
* build-tools/23.0.3 (23.0.3)
 +
* build-tools/24.0.0 (24)
 +
* build-tools/24.0.1 (24.0.1)
 +
* build-tools/24.0.2 (24.0.2)
 +
* build-tools/24.0.3 (24.0.3)
 +
* build-tools/25.0.0 (25)
 +
* build-tools/25.0.1 (25.0.1)
 +
* build-tools/25.0.2 (25.0.2)
 +
* build-tools/25.0.3 (25.0.3)
 +
* build-tools/26.0.0 (26)
 +
* build-tools/26.0.1 (26.0.1)
 +
* build-tools/26.0.2 (26.0.2)
 +
* build-tools/26.0.3 (26.0.3)
 +
* build-tools/27.0.0 (27)
 +
* build-tools/27.0.1 (27.0.1)
 +
* build-tools/27.0.2 (27.0.2)
 +
* build-tools/27.0.3 (27.0.3)
 +
* build-tools/28.0.0 (28)
 +
* build-tools/28.0.1 (28.0.1)
 +
* build-tools/28.0.2 (28.0.2)
 +
* build-tools/28.0.3 (28.0.3)
 +
* build-tools/29.0.2 (29.0.2)
 +
* build-tools/29.0.3 (29.0.3)
 +
* extras/android/m2repository (47.0.0)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.1 (1)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.2 (1)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout/1.0.1 (1)
 +
* extras/m2repository/com/android/support/constraint/constraint-layout/1.0.2 (1)
 +
* ndk/21.4.7075529 (21.4.7075529)
 +
* ndk/22.1.7171670 (22.1.7171670)
 +
* platform-tools (29.0.6)
 +
* platforms/android-10 (2)
 +
* platforms/android-11 (2)
 +
* platforms/android-12 (3)
 +
* platforms/android-13 (1)
 +
* platforms/android-14 (4)
 +
* platforms/android-15 (5)
 +
* platforms/android-16 (5)
 +
* platforms/android-17 (3)
 +
* platforms/android-18 (3)
 +
* platforms/android-19 (4)
 +
* platforms/android-20 (2)
 +
* platforms/android-21 (2)
 +
* platforms/android-22 (2)
 +
* platforms/android-23 (3)
 +
* platforms/android-24 (2)
 +
* platforms/android-25 (3)
 +
* platforms/android-26 (2)
 +
* platforms/android-27 (3)
 +
* platforms/android-28 (6)
 +
* platforms/android-29 (4)
 +
* platforms/android-7 (3)
 +
* platforms/android-8 (3)
 +
* platforms/android-9 (2)
 +
* r21e (None)
 +
* r22b (None)
 +
* tools (25.2.5)
  
  
 
== Build Log ==
 
== Build Log ==
  
'Build.py failed on server for wtf.technodisaster.tldr:2.1.1'
+
Build succeeded
=detail=
+
<pre>
+
== Installed Android Tools ==
+
 
+
2021-10-25 23:26:50,112 DEBUG: Reading 'config.yml'
+
2021-10-25 23:26:50,123 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner
+
2021-10-25 23:26:50,126 INFO: Creating log directory
+
2021-10-25 23:26:50,126 INFO: Creating temporary directory
+
2021-10-25 23:26:50,126 INFO: Creating output directory
+
2021-10-25 23:26:50,129 DEBUG: Getting git vcs interface for https://github.com/Techno-Disaster/tldr-flutter.git
+
2021-10-25 23:26:50,129 DEBUG: > git --version
+
git version 2.11.0
+
2021-10-25 23:26:50,344 INFO: Using git version 2.11.0
+
2021-10-25 23:26:50,345 DEBUG: Checking 2.1.1
+
2021-10-25 23:26:50,345 INFO: Building version 2.1.1 (5) of wtf.technodisaster.tldr
+
2021-10-25 23:26:50,346 DEBUG: > sudo passwd --lock root
+
passwd: password expiry information changed.
+
2021-10-25 23:26:50,720 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
+
(Reading database ... 64914 files and directories currently installed.)
+
Removing sudo (1.8.19p1-2.1+deb9u3) ...
+
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
+
Processing triggers for systemd (232-25+deb9u13) ...
+
2021-10-25 23:26:56,229 INFO: Getting source for revision 6bed7f19f7446696cb1502931fe8da641a93b7c8
+
2021-10-25 23:26:56,230 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:26:56,230 DEBUG: > git rev-parse --show-toplevel
+
2021-10-25 23:26:56,488 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:26:56,489 DEBUG: > git submodule foreach --recursive git reset --hard
+
2021-10-25 23:26:56,954 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:26:56,954 DEBUG: > git reset --hard
+
2021-10-25 23:26:57,260 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:26:57,260 DEBUG: > git submodule foreach --recursive git clean -dffx
+
2021-10-25 23:26:57,369 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:26:57,369 DEBUG: > git clean -dffx
+
2021-10-25 23:26:57,473 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:26:57,474 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
+
2021-10-25 23:27:00,254 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:27:00,255 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
+
2021-10-25 23:27:00,594 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:27:00,594 DEBUG: > git remote set-head origin --auto
+
2021-10-25 23:27:01,201 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:27:01,201 DEBUG: > git checkout -f 6bed7f19f7446696cb1502931fe8da641a93b7c8
+
2021-10-25 23:27:01,409 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:27:01,409 DEBUG: > git clean -dffx
+
2021-10-25 23:27:01,523 INFO: Collecting source libraries
+
2021-10-25 23:27:01,604 DEBUG: Removing debuggable flags from build/srclib/flutter
+
2021-10-25 23:27:01,657 INFO: Creating local.properties file at build/wtf.technodisaster.tldr/local.properties
+
2021-10-25 23:27:01,657 DEBUG: Removing debuggable flags from build/wtf.technodisaster.tldr
+
2021-10-25 23:27:01,663 INFO: Cleaned build.gradle of keysigning configs at build/wtf.technodisaster.tldr/android/app/build.gradle
+
2021-10-25 23:27:01,671 INFO: Scanning source for common problems...
+
2021-10-25 23:27:01,684 INFO: Creating source tarball...
+
2021-10-25 23:27:02,452 INFO: Running 'build' commands in build/wtf.technodisaster.tldr
+
2021-10-25 23:27:02,452 DEBUG: Directory: build/wtf.technodisaster.tldr
+
2021-10-25 23:27:02,452 DEBUG: > bash -x -c /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics && /home/vagrant/build/srclib/flutter/bin/flutter build apk --no-sound-null-safety
+
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
+
Downloading Dart SDK from Flutter engine d3ea636dc5d16b56819f3266241e1f708979c233...
+
  % Total    % Received % Xferd  Average Speed  Time    Time    Time  Current
+
                                Dload  Upload  Total  Spent    Left  Speed
+
 
+
  0    0    0    0    0    0      0      0 --:--:-- --:--:-- --:--:--    0
+
  0  221M    0 11103    0    0  30022      0  2:08:54 --:--:--  2:08:54 30008
+
46  221M  46  103M    0    0  77.0M      0  0:00:02  0:00:01  0:00:01 77.0M
+
95  221M  95  212M    0    0  90.5M      0  0:00:02  0:00:02 --:--:-- 90.5M
+
100  221M  100  221M    0    0  91.3M      0  0:00:02  0:00:02 --:--:-- 91.3M
+
Building flutter tool...
+
 
+
  ╔════════════════════════════════════════════════════════════════════════════╗
+
  ║                Welcome to Flutter! - https://flutter.dev                  ║
+
  ║                                                                            ║
+
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
+
  ║ statistics and basic crash reports. This data is used to help improve      ║
+
  ║ Flutter tools over time.                                                  ║
+
  ║                                                                            ║
+
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
+
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
+
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
+
  ║ event will be sent, and then no further information will be sent by the    ║
+
  ║ Flutter tool.                                                              ║
+
  ║                                                                            ║
+
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
+
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
+
  ║ service.                                                                  ║
+
  ║                                                                            ║
+
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
+
  ║ crash reports to Google.                                                  ║
+
  ║                                                                            ║
+
  ║ Read about data we send with crash reports:                                ║
+
  ║ https://flutter.dev/docs/reference/crash-reporting                        ║
+
  ║                                                                            ║
+
  ║ See Google's privacy policy:                                              ║
+
  ║ https://policies.google.com/privacy                                        ║
+
  ╚════════════════════════════════════════════════════════════════════════════╝
+
 
+
Analytics reporting disabled.
+
 
+
You may need to restart any open editors for them to read new settings.
+
+ /home/vagrant/build/srclib/flutter/bin/flutter build apk --no-sound-null-safety
+
Downloading Material fonts...                                      387ms
+
Downloading Gradle Wrapper...                                      15ms
+
Downloading package sky_engine...                                  135ms
+
Downloading flutter_patched_sdk tools...                          266ms
+
Downloading flutter_patched_sdk_product tools...                  243ms
+
Downloading linux-x64 tools...                                  1,354ms
+
Downloading linux-x64/font-subset tools...                        164ms
+
Downloading android-arm-profile/linux-x64 tools...                224ms
+
Downloading android-arm-release/linux-x64 tools...                208ms
+
Downloading android-arm64-profile/linux-x64 tools...              220ms
+
Downloading android-arm64-release/linux-x64 tools...              202ms
+
Downloading android-x64-profile/linux-x64 tools...                335ms
+
Downloading android-x64-release/linux-x64 tools...                208ms
+
Running "flutter pub get" in wtf.technodisaster.tldr...       
+
Warning: You are using these overridden dependencies:
+
! markdown 4.0.0
+
Running "flutter pub get" in wtf.technodisaster.tldr...            14.9s
+
 
+
Building without sound null safety
+
For more information see https://dart.dev/null-safety/unsound-null-safety
+
 
+
Running Gradle task 'assembleRelease'...                       
+
 
+
FAILURE: Build failed with an exception.
+
 
+
* Where:
+
Build file '/home/vagrant/build/wtf.technodisaster.tldr/android/app/build.gradle' line: 24
+
 
+
* What went wrong:
+
A problem occurred evaluating project ':app'.
+
> Failed to apply plugin 'com.android.internal.application'.
+
  > Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.
+
    You can try some of the following options:
+
      - changing the IDE settings.
+
      - changing the JAVA_HOME environment variable.
+
      - changing `org.gradle.java.home` in `gradle.properties`.
+
 
+
* Try:
+
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
+
 
+
* Get more help at https://help.gradle.org
+
 
+
BUILD FAILED in 41s
+
Running Gradle task 'assembleRelease'...                          45.5s
+
Gradle task assembleRelease failed with exit code 1
+
2021-10-25 23:28:48,181 ERROR: Could not build app wtf.technodisaster.tldr: Error running build command for wtf.technodisaster.tldr:2.1.1
+
==== detail begin ====
+
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
+
Downloading Dart SDK from Flutter engine d3ea636dc5d16b56819f3266241e1f708979c233...
+
  % Total    % Received % Xferd  Average Speed  Time    Time    Time  Current
+
                                Dload  Upload  Total  Spent    Left  Speed
+
 
+
  0    0    0    0    0    0      0      0 --:--:-- --:--:-- --:--:--    0
+
  0  221M    0 11103    0    0  30022      0  2:08:54 --:--:--  2:08:54 30008
+
46  221M  46  103M    0    0  77.0M      0  0:00:02  0:00:01  0:00:01 77.0M
+
95  221M  95  212M    0    0  90.5M      0  0:00:02  0:00:02 --:--:-- 90.5M
+
100  221M  100  221M    0    0  91.3M      0  0:00:02  0:00:02 --:--:-- 91.3M
+
Building flutter tool...
+
 
+
  ╔════════════════════════════════════════════════════════════════════════════╗
+
  ║                Welcome to Flutter! - https://flutter.dev                  ║
+
  ║                                                                            ║
+
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
+
  ║ statistics and basic crash reports. This data is used to help improve      ║
+
  ║ Flutter tools over time.                                                  ║
+
  ║                                                                            ║
+
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
+
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
+
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
+
  ║ event will be sent, and then no further information will be sent by the    ║
+
  ║ Flutter tool.                                                              ║
+
  ║                                                                            ║
+
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
+
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
+
  ║ service.                                                                  ║
+
  ║                                                                            ║
+
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
+
  ║ crash reports to Google.                                                  ║
+
  ║                                                                            ║
+
  ║ Read about data we send with crash reports:                                ║
+
  ║ https://flutter.dev/docs/reference/crash-reporting                        ║
+
  ║                                                                            ║
+
  ║ See Google's privacy policy:                                              ║
+
  ║ https://policies.google.com/privacy                                        ║
+
  ╚════════════════════════════════════════════════════════════════════════════╝
+
 
+
Analytics reporting disabled.
+
 
+
You may need to restart any open editors for them to read new settings.
+
+ /home/vagrant/build/srclib/flutter/bin/flutter build apk --no-sound-null-safety
+
Downloading Material fonts...                                      387ms
+
Downloading Gradle Wrapper...                                      15ms
+
Downloading package sky_engine...                                  135ms
+
Downloading flutter_patched_sdk tools...                          266ms
+
Downloading flutter_patched_sdk_product tools...                  243ms
+
Downloading linux-x64 tools...                                  1,354ms
+
Downloading linux-x64/font-subset tools...                        164ms
+
Downloading android-arm-profile/linux-x64 tools...                224ms
+
Downloading android-arm-release/linux-x64 tools...                208ms
+
Downloading android-arm64-profile/linux-x64 tools...              220ms
+
Downloading android-arm64-release/linux-x64 tools...              202ms
+
Downloading android-x64-profile/linux-x64 tools...                335ms
+
Downloading android-x64-release/linux-x64 tools...                208ms
+
Running "flutter pub get" in wtf.technodisaster.tldr...       
+
Warning: You are using these overridden dependencies:
+
! markdown 4.0.0
+
Running "flutter pub get" in wtf.technodisaster.tldr...            14.9s
+
 
+
Building without sound null safety
+
For more information see https://dart.dev/null-safety/unsound-null-safety
+
 
+
Running Gradle task 'assembleRelease'...                       
+
 
+
FAILURE: Build failed with an exception.
+
 
+
* Where:
+
Build file '/home/vagrant/build/wtf.technodisaster.tldr/android/app/build.gradle' line: 24
+
 
+
* What went wrong:
+
A problem occurred evaluating project ':app'.
+
> Failed to apply plugin 'com.android.internal.application'.
+
  > Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.
+
    You can try some of the following options:
+
      - changing the IDE settings.
+
      - changing the JAVA_HOME environment variable.
+
      - changing `org.gradle.java.home` in `gradle.properties`.
+
 
+
* Try:
+
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
+
 
+
* Get more help at https://help.gradle.org
+
 
+
BUILD FAILED in 41s
+
Running Gradle task 'assembleRelease'...                          45.5s
+
Gradle task assembleRelease failed with exit code 1
+
==== detail end ====
+
2021-10-25 23:28:48,181 DEBUG: Error encoutered, stopping by user request.
+
</pre>
+

Latest revision as of 00:12, 27 October 2021

Installed Android Tools

  • build-tools/19.1.0 (19.1)
  • build-tools/20.0.0 (20)
  • build-tools/21.1.2 (21.1.2)
  • build-tools/22.0.1 (22.0.1)
  • build-tools/23.0.1 (23.0.1)
  • build-tools/23.0.2 (23.0.2)
  • build-tools/23.0.3 (23.0.3)
  • build-tools/24.0.0 (24)
  • build-tools/24.0.1 (24.0.1)
  • build-tools/24.0.2 (24.0.2)
  • build-tools/24.0.3 (24.0.3)
  • build-tools/25.0.0 (25)
  • build-tools/25.0.1 (25.0.1)
  • build-tools/25.0.2 (25.0.2)
  • build-tools/25.0.3 (25.0.3)
  • build-tools/26.0.0 (26)
  • build-tools/26.0.1 (26.0.1)
  • build-tools/26.0.2 (26.0.2)
  • build-tools/26.0.3 (26.0.3)
  • build-tools/27.0.0 (27)
  • build-tools/27.0.1 (27.0.1)
  • build-tools/27.0.2 (27.0.2)
  • build-tools/27.0.3 (27.0.3)
  • build-tools/28.0.0 (28)
  • build-tools/28.0.1 (28.0.1)
  • build-tools/28.0.2 (28.0.2)
  • build-tools/28.0.3 (28.0.3)
  • build-tools/29.0.2 (29.0.2)
  • build-tools/29.0.3 (29.0.3)
  • extras/android/m2repository (47.0.0)
  • extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.1 (1)
  • extras/m2repository/com/android/support/constraint/constraint-layout-solver/1.0.2 (1)
  • extras/m2repository/com/android/support/constraint/constraint-layout/1.0.1 (1)
  • extras/m2repository/com/android/support/constraint/constraint-layout/1.0.2 (1)
  • ndk/21.4.7075529 (21.4.7075529)
  • ndk/22.1.7171670 (22.1.7171670)
  • platform-tools (29.0.6)
  • platforms/android-10 (2)
  • platforms/android-11 (2)
  • platforms/android-12 (3)
  • platforms/android-13 (1)
  • platforms/android-14 (4)
  • platforms/android-15 (5)
  • platforms/android-16 (5)
  • platforms/android-17 (3)
  • platforms/android-18 (3)
  • platforms/android-19 (4)
  • platforms/android-20 (2)
  • platforms/android-21 (2)
  • platforms/android-22 (2)
  • platforms/android-23 (3)
  • platforms/android-24 (2)
  • platforms/android-25 (3)
  • platforms/android-26 (2)
  • platforms/android-27 (3)
  • platforms/android-28 (6)
  • platforms/android-29 (4)
  • platforms/android-7 (3)
  • platforms/android-8 (3)
  • platforms/android-9 (2)
  • r21e (None)
  • r22b (None)
  • tools (25.2.5)


Build Log

Build succeeded