au.id.micolous.farebot

From F-Droid
Jump to: navigation, search

Metrodroid

Name: Metrodroid

ID: au.id.micolous.farebot

License: GPL-3.0-or-later

Site: https://micolous.github.io/metrodroid

Issues: https://github.com/micolous/metrodroid/issues

Source: https://github.com/micolous/metrodroid

Activity: https://gitlab.com/search?group_id=28397&scope=issues&search=au.id.micolous.farebot

Donate: None

Bitcoin: None

Added: 2017-01-11

Updated: 2017-08-30 (buildlog)

Metrodroid can read information from some public transport NFC smartcards - view in repository

Description

Metrodroid can read information from some public transport NFC smartcards. It was formerly known as Farebot M.

This is a fork of Eric Butler's Farebot project, with support for additional cards and bug fixes.

Supported cards:

- Bilhete Único - São Paulo, Brazil (1) (2) (5)

- Clipper - San Francisco, CA, USA

- EZ-Link - Singapore (3)

- Go card - Brisbane and South East Queensland, Australia (0) (1) (2)

- Manly Fast Ferry - Sydney (and surrounds), NSW, Australia (0) (1) (2)

- Matkakortti, HSL - Finland

- Myki - Melbourne (and surrounds), VIC, Australia (0) (4)

- MyWay - Australian Capital Territory, Australia (0) (1) (2) (5)

- NETS Flashpay - Singapore

- Octopus - Hong Kong (0)

- Opal - Sydney, NSW, Australia (0)

- ORCA - Seattle, WA, USA

- OV-chipkaart - Netherlands (1) (2)

- Shenzhen Tong - Shenzong, Guangdong Province, China (0)

- SmartRider - Western Australia, Australia (0) (1) (2)

- Suica, IOCOA, PASMO, Edy - Japan

- Transit Access Pass - Los Angeles, CA, USA (0) (1) (2)

(0): New in Metrodroid.

(1): Not compatible with all devices (Mifare Classic).

(2): Encryption keys are required to read this card.

(3): Not compatible with all devices (CEPAS).

(4): Only the card number can be read.

(5): Fallback reader -- must be explicitly enabled in the application's preferences.

You require a NFC-compatible phone in order to read cards.

You need a NXP NFC chipset in your phone in order to read MIFARE Classic cards. Some phones have NFC chips from other manufacturers, which do not read Mifare Classic cards (eg: Nexus 4, Nexus 5, Samsung Galaxy S4). Check the About screen in the app in order to determine if your phone supports MIFARE Classic.

Some agencies have encrypted cards. You will need to acquire encryption keys in order to read them. These are generally unique to each card. Sorry, I can't help you with this.

Some other agencies' cards using Cubic Nextfare on Mifare Classic may also work.

Maintainer Notes

Metadata: current history

Versions

We don't have the current version of this app. (Check mode: None) (Auto-update mode: None)

The current (recommended) version is 2.9.34 (version code 570).

v2.9.32-fdroid

We can't build this version: The build for this version was manually disabled. Reason: Could not find com.android.tools.build:gradle:3.0.0

Version code: 32

v2.9.31-fdroid

This version is built and signed by F-Droid, and guaranteed to correspond to the source tarball published with it.

Version code: 31

v2.9.30-fdroid

This version is built and signed by F-Droid, and guaranteed to correspond to the source tarball published with it.

Version code: 30