ee.ioc.phon.android.speak

From F-Droid
Jump to: navigation, search

Kõnele

Name: Kõnele

ID: ee.ioc.phon.android.speak

License: Apache-2.0

Site: https://kaljurand.github.io/K6nele/

Issues: https://github.com/Kaljurand/K6nele/issues

Source: https://github.com/Kaljurand/K6nele

Activity: https://gitlab.com/search?group_id=28397&scope=issues&search=ee.ioc.phon.android.speak

Donate: None

Bitcoin: None

Added: 2015-06-29

Updated: 2015-08-03 (buildlog)

Speech-to-text provider - view in repository

Description

Offers speech-to-text service to other apps. Apps which allow user input via voice usually have a little microphone button as part of their user interface. It is a free replacement for the proprietary Google voice search, based on the Net Speech API to communicate with a speech recognition server. Currently only estonian is supported by the pre-confgured server.

This is an UNTESTED build.

Maintainer Notes

We shouldn't build the net-speech-lib in prebuild, however build= will perform gradle checks _BEFORE_ building the lib. This will break for the main project, because it already requires the lib being in mavenlocal.

Building the lib in prebuild is wrong and leaves jars and class files which makes the scanner complain.

The makeIcons and makeDiagrams tasks don't provide `cleaning`, hence we cannot use preassemble= here.

Metadata: current history

Versions

We don't have the current version of this app. (Check mode: Tags) (Auto-update mode: None)

The current (recommended) version is 1.6.90 (version code 1690).

1.4.08

We can't build this version: The build for this version was manually disabled. Reason: build changed

Version code: 1408

1.2.06

This version is built and signed by F-Droid, and guaranteed to correspond to the source tarball published with it.

Version code: 1206

1.2.04

This version is built and signed by F-Droid, and guaranteed to correspond to the source tarball published with it.

Version code: 1204

1.2.00

We can't build this version: The build for this version was manually disabled. Reason: needs graphviz, needs testing

Version code: 1200