im.vector.alpha/lastbuild 81600

From F-Droid
Jump to: navigation, search

Installed Android Tools

Build Log

'Build.py failed on server for im.vector.alpha:0.8.16'

detail

[...]
l include/node/openssl/archs/linux32-s390x/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-x86_64/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-x32/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-ppc64/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-ppc/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-elf/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-armv4/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/linux-aarch64/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/darwin64-x86_64-cc/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/darwin-i386-cc/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/BSD-x86_64/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/BSD-x86/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/aix64-gcc/opensslconf.h
gyp verb extracted file from tarball include/node/openssl/archs/aix-gcc/opensslconf.h
gyp verb extracted file from tarball include/node/libplatform/libplatform-export.h
gyp verb extracted file from tarball include/node/libplatform/libplatform.h
gyp verb extracted file from tarball include/node/libplatform/v8-tracing.h
gyp verb tarball done parsing tarball
gyp verb check download content checksum, need to download `SHASUMS256.txt`... 
gyp verb checksum url https://nodejs.org/download/release/v8.12.0/SHASUMS256.txt
gyp http GET https://nodejs.org/download/release/v8.12.0/SHASUMS256.txt
gyp http 200 https://nodejs.org/download/release/v8.12.0/SHASUMS256.txt
gyp verb checksum data {"node-v8.12.0-aix-ppc64.tar.gz":"6a514208421b0643769fb7064d2edaadedd10c6eef4647b645907481e575fca6","node-v8.12.0-darwin-x64.tar.gz":"ca131b84dfcf2b6f653a6521d31f7a108ad7d83f4d7e781945b2eca8172064aa","node-v8.12.0-darwin-x64.tar.xz":"2d8b162cfc568d3d585c459fa0ded25b6d64e5f984a73bc0f89f2d6e5461baa3","node-v8.12.0-headers.tar.gz":"68768e555161e54795fb61ac3de3de0933638f6356a8cead097b34eab16a1aa3","node-v8.12.0-headers.tar.xz":"a5a8b2bdc0e202dfd8a0d2ee3667e28ec828b1c06f62d0c627cfbe262f173b51","node-v8.12.0-linux-arm64.tar.gz":"781ecf1ecb14b4c671ef0732988636282d6fb7071c4bd52567f663b008796bc9","node-v8.12.0-linux-arm64.tar.xz":"0fbdcfd8cf0cb5e8f5beff84ba091fd47126ba44c628e3a351501419b211aa1a","node-v8.12.0-linux-armv6l.tar.gz":"d7e9d6666075fa210767215b333bf9fb45f2e049b80e01208054749cd782d47e","node-v8.12.0-linux-armv6l.tar.xz":"699ff3799f1b6374be342b1ae0e71b69507cc431cd3094d791f00a10d7673fdb","node-v8.12.0-linux-armv7l.tar.gz":"9c564069c5c9f0c9062cb399db02670c79fc4a2a079e67edcc5785a73a663f6e","node-v8.12.0-linux-armv7l.tar.xz":"a437f347e12d499f72edea97ebd127abe403417316a3f23cba7e1db6fcf770d1","node-v8.12.0-linux-ppc64le.tar.gz":"a0c52c8f175566b1b6664ea9bbb82ba93c17c0178d2148368ed070d7a54da291","node-v8.12.0-linux-ppc64le.tar.xz":"3070989b41045faea4a923ea9d290ab9ac0983e462fc435e645b002ead05de68","node-v8.12.0-linux-s390x.tar.gz":"7e13da69c0932800ba1d6d96c95ebaf520cc220d6ff61ca1d0b544c61ee84628","node-v8.12.0-linux-s390x.tar.xz":"ac5d0645af733d5f9eb49caf27d2cb72f9ed0858806af2c967aff23c7ad40ede","node-v8.12.0-linux-x64.tar.gz":"3df19b748ee2b6dfe3a03448ebc6186a3a86aeab557018d77a0f7f3314594ef6","node-v8.12.0-linux-x64.tar.xz":"29a20479cd1e3a03396a4e74a1784ccdd1cf2f96928b56f6ffa4c8dae40c88f2","node-v8.12.0-linux-x86.tar.gz":"56ecffbd8a656991f71e4b53ab00af333c97453062cadc20a2103b933088d24d","node-v8.12.0-linux-x86.tar.xz":"2f9820411c5d53a19daf85d575f01f99664d2aff1c85c281c7b12d8086b83b31","node-v8.12.0.pkg":"c11b745e28628a89eaf667031541ab58c2c2f0baf03f7aecf36d668463a59c62","node-v8.12.0-sunos-x64.tar.gz":"74664b84c571c608943dc1dfff53d3eb058f929f5dba763d779b830cddef3331","node-v8.12.0-sunos-x64.tar.xz":"69aa7141050924079ffc9b1c8d76fe22b2801e6a71ac57a473c3553e2a91e38c","node-v8.12.0-sunos-x86.tar.gz":"05ac84818d45e64b0958f7bd81e073c5b8ca7bd9d7f71569ae8e511aeefaae09","node-v8.12.0-sunos-x86.tar.xz":"cca30c21f932d13ca4b31ccfbe57711c6c52006ac49fd53c90c8ba7d8ff4e09b","node-v8.12.0.tar.gz":"b4797843136edd9195c28221a1680ae52c29d867fc5fc1c99f7d6e2f2126a67b","node-v8.12.0.tar.xz":"5a9dff58016c18fb4bf902d963b124ff058a550ebcd9840c677757387bce419a","node-v8.12.0-win-x64.7z":"c1fb949ca07542b491b896d73e9606bd26501bbaae8deb8b1e3dd8652349a6b6","node-v8.12.0-win-x64.zip":"9b22c9b23148b61ea0052826b3ac0255b8a3a542c125272b8f014f15bf11b091","node-v8.12.0-win-x86.7z":"4516c85c7b353fb6b8c5116f72c553c7ff52fe6801119cf0afc8d7d3a11c08f1","node-v8.12.0-win-x86.zip":"f3c7f4b06c1252137ad5bc416bc5b347c58c271d32cd6e6030a624aa21b1bdfd","node-v8.12.0-x64.msi":"e359b26b8ba52eb24c49af6222c4bf9e454d3d266290897b492e13fc2f06e316","node-v8.12.0-x86.msi":"0e7b5601c6819d5fd042f21dc375c9cf067fa43c7ecb84ca8ce3646ae9624e73","win-x64/node.exe":"b270192df4ebc036b8ce1898244c28bfeb89992ac89c8f73c60a458faf57d93a","win-x64/node.lib":"9206d0c000a2ea83e41bfaa00ac001b8b3cd9e6c6ba8f5f6826bf26dbedf396a","win-x64/node_pdb.7z":"0d0687170293f839e2a0bcf97e38163bb68a1043b29b7609e75dbc9bbe53b5fc","win-x64/node_pdb.zip":"47897e35f3316f9271e7a26ac6d81d22b1a43a7319a2aacc4304b45e0296cf5b","win-x86/node.exe":"4ce2168afe0f7c5bfe070b3d4741c1d492d6d00a6076c6903f9097b8ab061036","win-x86/node.lib":"d042cab5ef26cec479fb001bf7cfea2aa14570efae3b7edecd8dde5e7ae01747","win-x86/node_pdb.7z":"350c96042bfc6106eb78e60c270239c51c89697eb5c3f242eea5e3f90aa53654","win-x86/node_pdb.zip":"98db5e9cb1b36be698b91b964fd4c3353075f4de650deb20deb4043a11aa94e3"}
gyp verb download contents checksum {"node-v8.12.0-headers.tar.gz":"68768e555161e54795fb61ac3de3de0933638f6356a8cead097b34eab16a1aa3"}
gyp verb validating download checksum for node-v8.12.0-headers.tar.gz (68768e555161e54795fb61ac3de3de0933638f6356a8cead097b34eab16a1aa3 == 68768e555161e54795fb61ac3de3de0933638f6356a8cead097b34eab16a1aa3)
gyp verb get node dir target node version installed: 8.12.0
gyp verb build dir attempting to create "build" dir: /home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/build
gyp verb build dir "build" dir needed to be created? /home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/build
gyp verb build/config.gypi creating config file
gyp verb build/config.gypi writing out config file: /home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/build/config.gypi
gyp verb config.gypi checking for gypi file: /home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/config.gypi
gyp verb common.gypi checking for gypi file: /home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/common.gypi
gyp verb gyp gyp format was not specified; forcing "make"
gyp info spawn /usr/bin/python2
gyp info spawn args [ '/home/vagrant/build/srclib/jitsi-meet/node_modules/node-gyp/gyp/gyp_main.py',
gyp info spawn args   'binding.gyp',
gyp info spawn args   '-f',
gyp info spawn args   'make',
gyp info spawn args   '-I',
gyp info spawn args   '/home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/build/config.gypi',
gyp info spawn args   '-I',
gyp info spawn args   '/home/vagrant/build/srclib/jitsi-meet/node_modules/node-gyp/addon.gypi',
gyp info spawn args   '-I',
gyp info spawn args   '/home/vagrant/.node-gyp/8.12.0/include/node/common.gypi',
gyp info spawn args   '-Dlibrary=shared_library',
gyp info spawn args   '-Dvisibility=default',
gyp info spawn args   '-Dnode_root_dir=/home/vagrant/.node-gyp/8.12.0',
gyp info spawn args   '-Dnode_gyp_dir=/home/vagrant/build/srclib/jitsi-meet/node_modules/node-gyp',
gyp info spawn args   '-Dnode_lib_file=/home/vagrant/.node-gyp/8.12.0/<(target_arch)/node.lib',
gyp info spawn args   '-Dmodule_root_dir=/home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass',
gyp info spawn args   '-Dnode_engine=v8',
gyp info spawn args   '--depth=.',
gyp info spawn args   '--no-parallel',
gyp info spawn args   '--generator-output',
gyp info spawn args   'build',
gyp info spawn args   '-Goutput_dir=.' ]
gyp verb command build []
gyp verb build type Release
gyp verb architecture x64
gyp verb node dev dir /home/vagrant/.node-gyp/8.12.0
gyp verb `which` succeeded for `make` /usr/bin/make
gyp info spawn make
gyp info spawn args [ 'V=1', 'BUILDTYPE=Release', '-C', 'build' ]
make: Entering directory '/home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/build'
  g++ '-DNODE_GYP_MODULE_NAME=libsass' '-DUSING_UV_SHARED=1' '-DUSING_V8_SHARED=1' '-DV8_DEPRECATION_WARNINGS=1' '-D_LARGEFILE_SOURCE' '-D_FILE_OFFSET_BITS=64' '-DLIBSASS_VERSION="3.3.6"' -I/home/vagrant/.node-gyp/8.12.0/include/node -I/home/vagrant/.node-gyp/8.12.0/src -I/home/vagrant/.node-gyp/8.12.0/deps/openssl/config -I/home/vagrant/.node-gyp/8.12.0/deps/openssl/openssl/include -I/home/vagrant/.node-gyp/8.12.0/deps/uv/include -I/home/vagrant/.node-gyp/8.12.0/deps/zlib -I/home/vagrant/.node-gyp/8.12.0/deps/v8/include -I../src/libsass/include  -fPIC -pthread -Wall -Wextra -Wno-unused-parameter -m64 -O3 -fno-omit-frame-pointer -std=gnu++0x -std=c++0x -fexceptions -frtti -MMD -MF ./Release/.deps/Release/obj.target/libsass/src/libsass/src/ast.o.d.raw   -c -o Release/obj.target/libsass/src/libsass/src/ast.o ../src/libsass/src/ast.cpp
make: g++: Command not found
src/libsass.target.mk:145: recipe for target 'Release/obj.target/libsass/src/libsass/src/ast.o' failed
make: *** [Release/obj.target/libsass/src/libsass/src/ast.o] Error 127
make: Leaving directory '/home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/home/vagrant/build/srclib/jitsi-meet/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack     at emitTwo (events.js:126:13)
gyp ERR! stack     at ChildProcess.emit (events.js:214:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
gyp ERR! System Linux 4.9.0-7-amd64
gyp ERR! command "/usr/local/bin/node" "/home/vagrant/build/srclib/jitsi-meet/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd /home/vagrant/build/srclib/jitsi-meet/node_modules/node-sass
gyp ERR! node -v v8.12.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok 
Build failed with error code: 1
npm WARN @atlaskit/avatar@8.0.5 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/button@5.4.2 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/dropdown-menu@3.10.2 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/dropdown-menu@3.10.2 requires a peer of react-dom@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@8.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN styled-components@1.4.6 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/droplist@4.11.1 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/droplist@4.11.1 requires a peer of react-dom@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@8.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN styled-components@1.4.6 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/field-text@4.0.1 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/flag@6.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@7.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@10.0.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/inline-dialog@5.0.2 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/inline-dialog@5.0.2 requires a peer of react-dom@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/inline-message@3.0.1 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/inline-message@3.0.1 requires a peer of react-dom@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@7.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/button@3.6.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/lozenge@3.4.2 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/modal-dialog@2.6.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/multi-select@7.1.3 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/multi-select@7.1.3 requires a peer of react-dom@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@6.6.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/spinner@3.4.2 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/spinner@4.0.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/tabs@4.0.1 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/theme@2.2.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/tooltip@6.0.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN react-native@0.50.4 requires a peer of react@16.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN styled-components@1.3.0 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN styled-components@1.4.6 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/blanket@2.4.3 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN ajv-keywords@3.2.0 requires a peer of ajv@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! node-sass@3.13.1 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the node-sass@3.13.1 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/vagrant/.npm/_logs/2018-10-10T03_09_07_128Z-debug.log
==== detail end ====