info.guardianproject.locationprivacy

From F-Droid
Jump to: navigation, search

LocationPrivacy

Name: LocationPrivacy

ID: info.guardianproject.locationprivacy

License: GPL-3.0-or-later

Site: https://guardianproject.info/2015/01/23/sharing-your-location-privately

Issues: https://dev.guardianproject.info/projects/panic/issues

Source: https://github.com/guardianproject/LocationPrivacy

Activity: https://gitlab.com/search?group_id=28397&scope=issues&search=info.guardianproject.locationprivacy

Donate: None

Bitcoin: 1Fi5xUHiAPRKxHvyUGVFGt9extBe8Srdbk

Added:

Updated: (buildlog)

Filter for various ways of sharing location - view in repository

Description

LocationPrivacy is not really app but rather a set of "Intent Filters" for all of the various ways of sharing location. When you share location from one app, LocationPrivacy offers itself as an option. It then recognizes insecure methods of sharing location, and then converts them to more secure methods. This mostly means that it rewrites URLs to use https, and even to use geo: URIs, which can work on fully offline setups. LocationPrivacy mostly works by reading the location information from the URL itself. For many URLs, LocationPrivacy must actually load some of the webpage in order to get the location.

LocationPrivacy can also serve as a way to redirect all location links to your favorite mapping app. All map apps in Android can view geo: URIs, and LocationPrivacy converts many kinds of links to geo: URIs, including: Google Maps, OpenStreetMap, Amap, Baidu Map, QQ Map, Nokia HERE, Yandex Maps.

Maintainer Notes

Metadata: current history

Versions

We don't have the current version of this app. (Check mode: Tags) (Auto-update mode: None)

The current (recommended) version is 0.3 (version code 30).

0.3

We can't build this version: The build for this version was manually disabled. Reason: does not verify

Version code: 30

0.2

We can't build this version: The build for this version was manually disabled. Reason: does not verify

Version code: 20

0.1

We can't build this version: The build for this version was manually disabled. Reason: does not verify

Version code: 10